+0  
 
+1
163
6
avatar+436 

Apparently, it says that web2.0calc's security certificate expired. The only way for me to get onto this site is to go to "advanced" then to "Proceed to web2.0calc (unsafe)". Is it only a problem with me, or is it occurring with everyone?

 Jun 3, 2021
 #1
avatar+34315 
+1

Same here.....    happened before....

 Jun 3, 2021
 #2
avatar
+1

The same thing happened to me on my laptop.

I am currently using my phone to reach this website.

 

=^._.^=

 Jun 3, 2021
 #3
avatar+114462 
+1

It is happening to me too.  I have sent a message to admin. Hopefully it will be fixed soon.

 Jun 3, 2021
 #4
avatar+775 
+1

Says certificate is valid for me... no popup shows- I tried this with every browser (edge,safari,chrome,chromium,firefox) and it does not show up. On a 2017 MacOS High Sierra 10.13.4

 #5
avatar+2152 
0

its fine for me....

 Jun 3, 2021
 #6
avatar+114462 
0

It is fixed, thanks Admin  laugh

 Jun 3, 2021

23 Online Users

avatar
avatar